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Sci-Fi button 
worksheet 

A taste of 
user interface 
(UI) design - creating
a sci-fi button 
Workshop developed by 
Aiden Le Santo 

Objectives 

• To understand the role of a UI designer 

• To design a prototype button that could be used 
for a sci-fi game 

• To see related areas of employment 

Materials required 

Adobe Photoshop and Illustrator. A free trial, if 
required, can be downloaded here 

Introduction 

UX/UI is the design of user interfaces (or menu
systems) for machines and software, such as
computers, home appliances, mobile devices, and
other electronic devices, with the focus on making
user friendly and contextually appropriate products. 

Sprung Studios are one of the world’s leading 
UI design studios who specialise in Video Games 
and Aiden has worked on projects such as 
Injustice 2, Call of Duty (War Zone and Modern 
Warfare), Fast and Furious Take Down and 
Trials Rising. 

This task will begin in Adobe Illustrator to create a 
basic shape, before copying it into Adobe Photoshop 
to apply colour and effects. 

1. Setting up the canvas 

• Open Adobe Illustrator, or an alternative Vector 
Graphics program like Inkscape or Affinity 

• Create a new canvas. Start with 1000 x 1000 
pixels (px) 

https://www.adobe.com/uk/creativecloud/catalog/desktop.html?gclid=EAIaIQobChMI5MS-1KT16gIVRrDtCh28QQg8EAAYASAAEgIR8_D_BwE&sdid=88X75SKR&mv=search&ef_id=EAIaIQobChMI5MS-1KT16gIVRrDtCh28QQg8EAAYASAAEgIR8_D_BwE:G:s&s_kwcid=AL!3085!3!273770024043!e!!g!!adobe%2520free%2520trial!1422700265!54632141663


 
 

2. Basic tools in illustrator 

These are a few of the key
tools we will use throughout
this first section: 

• The Selection Tool (V) for selecting objects on
the canvas 

• Rectangle or Shape Tool (M) for drawing
objects 

• Right click on this tool to choose different 
shapes such as Ellipse or Polygon 

• You may also want to use the Zoom tool to 
zoom in or out at any point 

Top tip: 
Instead of dragging to

create the rectangle, you
can also just click once

anywhere on the canvas to
set the size manually using

this dialogue box. 

3. Create a shape 

• In the Toolbar, find the Shape Tool and choose 
the Rectangle Tool. Alternatively, press (M) on 
the keyboard for a shortcut 

• Click and Drag to draw a rectangle 

• Using the Selection Tool (V), click on the 
Rectangle and set the size to 540 x 160 px 
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4. Customising the corners 

Go to Window > Transform and check that it 
is ticked on 

This will display the Transform Panel, 
where you can change the properties of
a selected object. 

• Select the Rectangle using the Selection
Tool (V) 

• Look to the Transform Panel and make 
sure the ‘Link’ icon has a cross through it. 
This will let us change each
corner independently 

• Set the top left and bottom right corners
to 40px 

• Click on the small icon next to the pixel value and change
the ‘Corner Type’ to ‘Chamfer’ 

• This gives us a cut-corner effect, perfect for the Sci-Fi 
theme 

• Do the same for the bottom right corner 

Now we have our 
basic shape 

We are going to take this into 
Photoshop to add colour, 

effects and text. 
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5. Copy the shape The Type tool to create a text box. 

• Using the Selection Tool (V) click on the 
Rectangle 

• Press Cmd + C (Mac) or Ctrl + C (Windows) to 
copy the shape 

6. Create a canvas in Photoshop 

• Open Photoshop and Create a new document 

• We’ll use 1000 x 1000 px again and set the
Resolution to 72 and the Color Mode to RGB. 

The direct selection tool to select and change the
properties of an individual shape. 

7. Basic Photoshop tools 

These are some of the tools and panels I will refer to
throughout this section. 

The move tool to click and drag a layer around on
the canvas. 
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These tools can be selected from 
the Tool Bar on the left side of the 
screen, which may look slightly
different depending on your 
preferences. 

The shape should now be placed on the canvas.
It should also be its own “Shape” layer in the
Layer Palette. 

We’ll also be interacting with the 
Layer Panel. 

If you can’t see this, go to
Window > Layers and make sure 
it is ticked ON. 

The panel will normally be in the
bottom right of the screen. 

8. Pasting the shape
from illustrator 

• Before moving our shape into
Photoshop, Press “D” on the 
keyboard to reset the default
foreground colour to Black.
This just makes sure that our
shape will be black so we can
easily see it. 

• While in Photoshop, press
Cmd + V (Mac) or Ctrl + 
V (Windows) to paste the
Rectangle we copied from
Illustrator. 

• When prompted, choose
‘Shape Layer’ as the type.
This will make it a vector shape

meaning it will be easy to edit
and add styles later on. 

9. Changing the
background
colour 

We want a nice 
colour for the button 
to sit on. Add a 
Solid Colour Fill 
Layer to the canvas. 
Pick a dark colour. I 
used #000312. 

Note: In the Layer
Palette, make sure 
your Rectangle
(Shape 1) is above
the new Color Fill 
Layer. If it’s not, 
click and drag the
layers in the palette 
to rearrange. 
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10. Change the shape colour 11. Adding styles and effects 

Using the “Direct Selection Tool” click and drag to Double click the empty space next to the layer name
select the entire shape. to open the Layer Style dialogue. 

Once the shape is selected, click the ‘Fill’ colour 
swatch in the top bar. 

Note: If you can’t find this, go to Window > Options
and make sure it is ticked ON. 

This is where we can easily add effects such as 
borders, glows, gradients or shadows to a layer. 

Choose a colour for the button shape. Something
lighter than your background but still quite dark will
work well. I used #000d4d. 

12. Add a border (or “stroke”) 

The first style we are going to add will be a bright
border (also known as a “stroke”) to the shape. 

In the left hand list, click on ‘Stroke’. 

Note: Make sure you click on the actual word ‘Stroke’
not just the tickbox, in order to get the options to
appear on the right. 
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I used the following options: 

• Size: 5px 

• Position: Inside 

• Blend Mode: Normal 

• Opacity: 76% 

• Change the colour of the Stroke by setting the
Fill Type to ‘Gradient’. 

• Style: Reflected 

• Tick “Align with Layer” 

• Angle: 0º 

• Scale: 100% 

13. Now we need to customise the colours of 
the gradient. 

• Double click in the coloured box next to 
“Gradient:” to customise it 

• Pick a basic, two colour gradient from the preset
list (as a starting point, if needed) 

• Change each colour on the gradient by double
clicking the small coloured arrows underneath
the bar 

• Choose the colour for each end of the gradient 

I used #279cff for the light side and #0050e3 for the 
darker side. 
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This will create a shine effect around the edge of the 
button. Since the gradient is set to “Reflected”, this 
means that each colour is mirrored along the angle
we specified. 

The result is a lighter highlight in the middle of the
border, getting darker towards the left and right edges. 

14. Add an outer glow 

Add an outer glow in the same way as we did the
‘Stroke’, by clicking the word ‘Outer Glow’ in the left 
hand list. 

For the glow, pick a bright and saturated colour.
Play around with Opacity, Spread and Size until you
are happy. 

I used the following properties: 

• Colour: #0053cf 

• Opacity: 26% 

• Technique: Softer 

• Spread: 0% 

• Size: 62px 

The shape now has a soft blue glow around
the outside. 

15. Add an inner glow 

Using the same process, add an inner glow from the
list on the left hand side. Pick a bright colour, such as 
#00f6ff 

I used the following: 

• Blend Mode: Overlay 

• Opacity: 100% 

• Color: #00f6ff 

• Technique: Softer 

• Source: Edge 

• Size: 65px 
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Choose the ‘Pencil’ tool (it might be hidden under the 
Brush Tool in the Toolbar). 

16. Create a “Scanline” pattern Start drawing 1px blocks across the canvas in a
diagonal line, from one corner to the next.

We’re going to make a pattern that will tile across the 
button to create the effect of ‘scanlines’ - lots of thin, 
diagonal lines that create a high-tech feeling. 

Start off by creating a new canvas for the pattern. It 
will be really small - only 8px * 8px. 

The canvas will probably just look like a dot at first.
Press Ctrl + 0 (Windows) or Cmd + 0 (Mac) to zoom 
all the way in. 

When finished, we’ll turn 
it into a Pattern Swatch 

by going to Edit > Define 
Pattern. 
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Give it a name and press OK. Change the settings until you’re happy. 

We’ll want to keep the pattern quite subtle so it isn’t 
too overpowering. I used: 

• Blend Mode: Overlay 

• Opacity: 10% 

• Angle: 0º 

• Scale: 200% 

Return to the file containing your Button. 

Open up the Layer Style dialogue again by clicking in
the empty space next to the layer name. 

We now have a faint diagonal pattern going over the 
whole button. 

Then, add a Pattern Overlay from the list in the left.
Under the “Pattern” section, click the swatch to find 
your newly created pattern in the list. 

17. Add text to the button 

• Select the ‘Text’ tool from the Tool Bar on the left. 

• Click and drag somewhere on your canvas to
create a text box. 

• Type the text for your label, e.g. ‘Upgrade’ 

Note: Pick somewhere away from your button,
otherwise you might accidentally turn the button
shape into the text box. 
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Change the Font and Size to something you are
happy with. I’m using a Sci-Fi theme font called
Furore (which I downloaded for free) 

The size is 61pt. Align the text to the centre. 

Then use the Move Tool to drag the text into the
middle of your button. 

With the Text Tool selected, use the ‘handles’ on the 
edges of the Text box to resize it. Make the width the 
same as your button, so you know it’s in the middle. 

18. Adding styles to the text 

We are going to use Layer Styles again, but this
time we’ll add them to the Text Layer, not the 
Shape Layer. 

Click the empty space next to your text layer in the
Layer Panel. Add a Gradient Overlay 

I used: 

• Blend Mode: Normal 

• Opacity: 100% 

• Gradient: #a8f0ff to #e4eeff 

• Angle: 90º 

• Scale: 100% 

19. Now add an outer glow 

I used the following properties: 

• Blend Mode: Normal 

• Opacity: 40% 

• Color: #00eaff 

• Technique: Softer 

• Spread: 0% 

• Size: 30px 



 

Prnpenies Adjustments 

w: 20 px C-:J H: :co px J 
)t 230 px Y: 560 px - o px --v 

IgI E ltF 

Layers Channels Paths 

Kind 'V ~ Qi T □ ~ • 
OVllrfay V opacity: 100¾ 

FIii: 100% 

0 ~ Rectanglll 3 

Rectangl ll 2 copy 

Rectanglli 2 

20. Adding extra details 

We can now add some extra personality with details 
such as small dots or lines around the border. 

Make sure the Rectangle tool is set to “Shape” in the
top left, this will make sure we can easily edit it as we
go forwards. 

Use the rectangle tool to create some squares or lines
and then position them with the Move Tool. 

You might want to zoom in using the Zoom Tool to get 
a closer look. 

21. Changing the size of shapes 

Once you’ve created a shape, there’s a few ways to 
adjust the size of it: 

• Use the Direct Selection tool to select the 
‘points’ around the shape and click and 
drag them around, or nudge them with the
arrow keys. 

• Open the ‘Properties’ Panel and select the 
shape in your Layer palette. Adjust the width and 
height values manually. 

• Select the shape in the layer palette and press
Cmd + T or Ctrl + T to use “Free Transform” and 
use the handles to change the size 

Tip: When holding Shift, resizing will constrain the
proportions of the shape. For example, dragging
to resize a square will keep it a square, and not
squash it. 

When holding Alt, it will resize from a central point. 

Note: Some versions of Photoshop might have these
toggled the other way around, you can change it
in preferences! 

Using Direct Selection
tool to grab and

move points. 

Using the properties panel to resize a layer manually. 
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Using ‘Free Transform’ to resize by grabbing and 
dragging, or inserting values along the top bar. 
You can also rotate a shape here by hovering near the 
corner handles. 

22. Changing the colour, opacity and blend mode 
of shapes 

Feel free to change more aspects of your shapes. 

You can change things like the Size, Fill Colour or 
Stroke Colour of a Shape in the Properties panel. 

You can also change the Blend Mode and Opacity of 
an individual layer in the Layer Panel. 

Finished! Feel free to keep playing around with the
tools you have learned, to see what else you can do
with the design. 

Perhaps make a new one with a different shape or 
colour scheme? 

Conclusion 

Well done for taking part in this workshop. We hope 
you are happy with your button design. Perhaps you
can use this or the skills you have learnt for a school
or college project? The skills you have learnt from 
this project are not just about making something that
looks impressive. It is as important to consider how
and where this type of design will be used. The skills 
you have learnt today cross over with a number of
creative fields including; games design, visual effects, 
software engineering, and graphic design. 

Further resources: 

Screenskills 

Game Maker’s Toolkit 

Sprung Studios 

Useful links 
@norwichuniarts 

Creative Careers 
www.nua.ac.uk 

UCAS 

Or try exploring the other options in the Layer Styles
palette? 

https://discovercreative.careers/#/
https://www.ucas.com/
https://www.instagram.com/norwichuniarts/
https://www.nua.ac.uk/
https://www.screenskills.com/
https://www.youtube.com/watch?v=dBmIkEvEBtA&t=7s
https://www.sprungstudios.com/
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